PICkit 3, Windows 7, x64, No problem!

Author
SammyAU
New Member
  • Total Posts : 1
  • Reward points : 0
  • Joined: 2011/05/04 00:59:42
  • Location: 0
  • Status: offline
2011/05/04 01:17:39 (permalink)
0

PICkit 3, Windows 7, x64, No problem!

Solved. The pins on the demo board only just make contact with my PICkit (I've noticed this before).... always the simplest thing hey.

G'day,

PICkit 3 - whinge whinge whinge - I should have got a PICkit 2? or what is the most 'generic' programmer out there from Microchip? - but in the meantime, I wonder if any of you have any ideas about the following:


- I was previously using PICkit 3, Windows 7 x64 and the version of MPLAB IDE it shipped with (8.4? perhaps) and it all worked without any major hassles.


On the same machine I've just reformatted, re-installed Win 7 x64 and installed MPLAB IDE X. After a lot of frustration I can install PICkit 3 from the .inf files in the Switcher dir - but, it doesn't work in X or IDE. So I've now installed MPLAB IDE 8.63, uninstalled the drivers from MPLAB X, but cannot install drivers from IDE 8.63 ? .. Win 7 picks it up as a known device, as a "USB Input Device"... IDE 8.63 detects it, downloads appropriate firmware, but then PK3Err0045 - You must connect to a target device (when it is). Specifying the drivers from IDE I get the "Not 64 bit compatible blah". I've tried all the usual driver things, short of trying it on a new USB hub.... any thoughts before frustration gets the better of me and Pk3 is no more!?


(I'm testing it with the PIC18F45K20 debugger board, and I've also applied the patch - but no luck)

post edited by SammyAU - 2011/05/04 03:31:19
#1

0 Replies Related Threads

    Jump to:
    © 2017 APG vNext Commercial Version 4.5