Hot!I am new and need help!!!

Page: < 12345 Showing page 5 of 5
Author
qɥb
Monolothic Member
  • Total Posts : 3264
  • Reward points : 0
  • Joined: 2017/09/09 05:07:30
  • Location: Jupiter
  • Status: offline
Re: I am new and need help!!! 2018/08/09 19:14:18 (permalink)
0
Aso, if this is on a breadboard, the 0.1uF capacitor should be mounted as close as possible to the PIC's Vss and Vdd pins.
NOT at the end of a piece of wire!
 

This forum is mis-configured so it only works correctly if you access it via https protocol.
The Microchip website links to it using http protocol. Will they ever catch on?
PicForum "it just works"
#81
Gordon2005
Starting Member
  • Total Posts : 36
  • Reward points : 0
  • Joined: 2018/08/03 13:42:49
  • Location: 0
  • Status: offline
Re: I am new and need help!!! 2018/08/09 19:18:35 (permalink)
0
I am using MPLAB X IDE and to program MPLAB IPE. and the 0.1uf capacitor is as close as i can make it.
#82
Gordon2005
Starting Member
  • Total Posts : 36
  • Reward points : 0
  • Joined: 2018/08/03 13:42:49
  • Location: 0
  • Status: offline
Re: I am new and need help!!! 2018/08/09 19:36:39 (permalink)
+2 (2)
I tried programming through the IDE instead and the IPE and it worked IT FINALLY WORKED! I have been trying to get this to work for almost two years now. THANKYOU everyone for helping me.Smile: SmileSmile: SmileSmile: Smile!!!!!!!!!!
#83
qɥb
Monolothic Member
  • Total Posts : 3264
  • Reward points : 0
  • Joined: 2017/09/09 05:07:30
  • Location: Jupiter
  • Status: offline
Re: I am new and need help!!! 2018/08/09 20:28:33 (permalink)
0
Gordon2005
I tried programming through the IDE instead and the IPE

Why were you using the IPE?
Looking back, I can see you did mention it once back in post#4, but there were all sorts of other problems back then and that got missed.

This forum is mis-configured so it only works correctly if you access it via https protocol.
The Microchip website links to it using http protocol. Will they ever catch on?
PicForum "it just works"
#84
Gordon2005
Starting Member
  • Total Posts : 36
  • Reward points : 0
  • Joined: 2018/08/03 13:42:49
  • Location: 0
  • Status: offline
Re: I am new and need help!!! 2018/08/09 20:31:44 (permalink)
0
I used the IPE because it had a lot of settings and i didn't think it mattered.
#85
qɥb
Monolothic Member
  • Total Posts : 3264
  • Reward points : 0
  • Joined: 2017/09/09 05:07:30
  • Location: Jupiter
  • Status: offline
Re: I am new and need help!!! 2018/08/09 20:38:31 (permalink)
+1 (1)
"Lots of settings" is not necessarily a good thing!
Chances are it was holding the MCLR pin low when it finished programming, because it s a bulk programming tool, not a debugging environment.
Your chip might have run if you disconnected the programming cable after programming the PIC.
 
 

This forum is mis-configured so it only works correctly if you access it via https protocol.
The Microchip website links to it using http protocol. Will they ever catch on?
PicForum "it just works"
#86
Gordon2005
Starting Member
  • Total Posts : 36
  • Reward points : 0
  • Joined: 2018/08/03 13:42:49
  • Location: 0
  • Status: offline
Re: I am new and need help!!! 2018/08/09 20:56:37 (permalink)
0
thanks for the info. I probably wont use the IPE ever again
#87
PStechPaul
Super Member
  • Total Posts : 1950
  • Reward points : 0
  • Joined: 2006/06/27 16:11:32
  • Location: Cockeysville, MD, USA
  • Status: offline
Re: I am new and need help!!! 2018/08/09 22:08:41 (permalink)
+1 (1)
The IPE is useful for a small quantity production, where you can quickly open the application and program devices with hex files. It is designed to be safely used by production technicians where firmware changes are not wanted. There may be settings that allow power to stay on after programming, and/or take MCLR out of reset.

 
#88
johnszy
New Member
  • Total Posts : 8
  • Reward points : 0
  • Joined: 2015/09/29 15:33:45
  • Location: 0
  • Status: offline
Re: I am new and need help!!! 2018/08/13 21:28:35 (permalink)
0
You have your bits flipped.  RB0 is far right, 
Try:
 
PORTB = 0b00000001;
 
You have have turned on, RB5, pin 12
#89
qɥb
Monolothic Member
  • Total Posts : 3264
  • Reward points : 0
  • Joined: 2017/09/09 05:07:30
  • Location: Jupiter
  • Status: offline
Re: I am new and need help!!! 2018/08/13 22:53:13 (permalink)
+2 (2)
johnszy
You have your bits flipped.  RB0 is far right, 
Try:
 
PORTB = 0b00000001;
 
You have have turned on, RB5, pin 12


Did you read all the replies?
That was already pointed out in detail a week ago.
 

This forum is mis-configured so it only works correctly if you access it via https protocol.
The Microchip website links to it using http protocol. Will they ever catch on?
PicForum "it just works"
#90
katela
Super Member
  • Total Posts : 851
  • Reward points : 0
  • Joined: 2013/06/11 05:25:18
  • Location: South Africa
  • Status: offline
Re: I am new and need help!!! 2018/08/14 04:16:19 (permalink)
0
Gordon2005
it worked IT FINALLY WORKED! I have been trying to get this to work for almost two years now. 


Two Years!!! LoL

Free online Microcontroller Tutorials and Projects for Hobbyists and students. From beginners to advanced. Website: www.studentcompanion.co.za
YouTube Tutorials: https://www.youtube.com/user/StudentCompanionSA
#91
DavidBLit
Super Member
  • Total Posts : 1565
  • Reward points : 0
  • Joined: 2012/02/18 13:08:48
  • Location: The Land of Confusion
  • Status: offline
Re: I am new and need help!!! 2018/08/14 08:43:38 (permalink)
0
This train wreck of a thread feels like two years.

Yeah, "//Code and stuff".
#92
Gordon2005
Starting Member
  • Total Posts : 36
  • Reward points : 0
  • Joined: 2018/08/03 13:42:49
  • Location: 0
  • Status: offline
Re: I am new and need help!!! 2018/08/14 16:57:08 (permalink)
0
johnszy
You have your bits flipped.  RB0 is far right, 
Try:
 
PORTB = 0b00000001;
 
You have have turned on, RB5, pin 12


That's what i have been doing since the 2nd or 3rd comment. also does anyone know of a good tutorial, mine obviously isn't very good.
 
#93
katela
Super Member
  • Total Posts : 851
  • Reward points : 0
  • Joined: 2013/06/11 05:25:18
  • Location: South Africa
  • Status: offline
Re: I am new and need help!!! 2018/08/14 19:23:24 (permalink)
0
Gordon2005
 
does anyone know of a good tutorial, mine obviously isn't very good.
 


You can start here.

Free online Microcontroller Tutorials and Projects for Hobbyists and students. From beginners to advanced. Website: www.studentcompanion.co.za
YouTube Tutorials: https://www.youtube.com/user/StudentCompanionSA
#94
Page: < 12345 Showing page 5 of 5
Jump to:
© 2018 APG vNext Commercial Version 4.5