Hot!IPE4.20 still can not work for LVP on PIC16F1459

Author
uzslm
Super Member
  • Total Posts : 335
  • Reward points : 0
  • Joined: 2016/06/28 18:46:27
  • Location: 0
  • Status: offline
2018/06/13 06:21:29 (permalink)
0

IPE4.20 still can not work for LVP on PIC16F1459

for this issue ,i raised many posts and submitted a support case 00275467;
i believe that 4.20 is released to solve the problem marked with PK3-402 as below(in release note for PicKit3) :
 

5        Repairs and Enhancements Made in v4.20

PK3-402
RA0/RA1 port is not working for ICSP communication for low-voltage programming (LVP) mode.
PIC16F1459, 16F1455
 
 
 
in fact,i did a test today,LVP still can't work for my case,but i think it work in X IDE;
the Low voltage programming setting did not match betweem two seeting dialogs on new IPE;
i also attached a picture to show that. 
please kindly help how could i make LVP work on IPE4.20.
 
 
 
Thanks
uzslm
 
post edited by uzslm - 2018/06/13 06:28:42

Attached Image(s)

#1

9 Replies Related Threads

    tech24x7
    New Member
    • Total Posts : 29
    • Reward points : 0
    • Joined: 2013/10/14 21:38:52
    • Location: 0
    • Status: offline
    Re: IPE4.20 still can not work for LVP on PIC16F1459 2018/06/13 08:07:42 (permalink)
    0
    It looks like the view power setting is not updated,  however could you try enable the setting in power options and try to program.  Hope it should work.
    #2
    uzslm
    Super Member
    • Total Posts : 335
    • Reward points : 0
    • Joined: 2016/06/28 18:46:27
    • Location: 0
    • Status: offline
    Re: IPE4.20 still can not work for LVP on PIC16F1459 2018/06/13 08:29:07 (permalink)
    0
    i can check or uncheck the "use low power programming mode entry",but on power setting dialog,it is always showing "No";
    and low power programming always failed with error message:
     Format specifier '%x'
    #3
    vkalyan
    New Member
    • Total Posts : 8
    • Reward points : 0
    • Joined: 2016/02/15 22:26:47
    • Location: 0
    • Status: offline
    Re: IPE4.20 still can not work for LVP on PIC16F1459 2018/06/13 09:57:33 (permalink)
    0
    @uzslm
    Can you please post the complete error message that you are seeing in the output?
    #4
    uzslm
    Super Member
    • Total Posts : 335
    • Reward points : 0
    • Joined: 2016/06/28 18:46:27
    • Location: 0
    • Status: offline
    Re: IPE4.20 still can not work for LVP on PIC16F1459 2018/06/13 16:35:11 (permalink)
    0
    They have been in another post:http://www.microchip.com/forums/m1037022.aspx
    except that the error report was different with IPE4.10,as shown in the picture;
    #5
    HowardH
    Super Member
    • Total Posts : 796
    • Reward points : 0
    • Joined: 2006/01/20 10:21:24
    • Location: Microchip Technology - Chandler, AZ
    • Status: offline
    Re: IPE4.20 still can not work for LVP on PIC16F1459 2018/06/22 16:31:09 (permalink)
    0
    uzslm,
     
    We will revisit and I'll let you know.
     
    Thanks,
    Howard
    #6
    HowardH
    Super Member
    • Total Posts : 796
    • Reward points : 0
    • Joined: 2006/01/20 10:21:24
    • Location: Microchip Technology - Chandler, AZ
    • Status: offline
    Re: IPE4.20 still can not work for LVP on PIC16F1459 2018/06/22 16:59:21 (permalink)
    0
    Uzslm,
    Can you stick with v4.15 until we resolve the issue with v4.20?
     
    Thanks,
    Howard
    #7
    HowardH
    Super Member
    • Total Posts : 796
    • Reward points : 0
    • Joined: 2006/01/20 10:21:24
    • Location: Microchip Technology - Chandler, AZ
    • Status: offline
    Re: IPE4.20 still can not work for LVP on PIC16F1459 2018/06/26 08:55:15 (permalink)
    0
    Hi Uzslm,
    We've verified this is an issue.  Thanks for your patience as we try to repair this.
    Please continue to use v4.15 until this can be resolved.
     
    Best Regards,
    Howard
    #8
    uzslm
    Super Member
    • Total Posts : 335
    • Reward points : 0
    • Joined: 2016/06/28 18:46:27
    • Location: 0
    • Status: offline
    Re: IPE4.20 still can not work for LVP on PIC16F1459 2018/07/06 08:13:13 (permalink)
    0
    Thanks for update!
    How about if i use X IDE 4.20 for compiling and building;
    and still keep IPE 3.65 for hex downloading.
     
    uzslm 
    post edited by uzslm - 2018/07/06 08:14:57
    #9
    tech24x7
    New Member
    • Total Posts : 29
    • Reward points : 0
    • Joined: 2013/10/14 21:38:52
    • Location: 0
    • Status: offline
    Re: IPE4.20 still can not work for LVP on PIC16F1459 2018/07/23 23:24:34 (permalink)
    0
    You can use 4.20 IDE and use IPE 3.65 should be fine for using gen 3 tools.
    #10
    Jump to:
    © 2018 APG vNext Trial Version 4.5