Hot!PICKIT 4 not working

Page: 12 > Showing page 1 of 2
Author
Wollli
Junior Member
  • Total Posts : 56
  • Reward points : 0
  • Joined: 2013/04/06 04:34:46
  • Location: 0
  • Status: offline
2018/06/08 09:26:19 (permalink)
0

PICKIT 4 not working

I now tried the PICKIT 4 on 3 different Hardware platforms and processors:
PIC32MZ2048EFM, PIC32MX795, PIC16F877A
 
NON of this processors is programmable with PICKIT 4!
All of them are programmable with PICKIT3 and ICD3.
 
On the PIC16F877A the PICKIT4 is found but with double red marked. Why ?
On the PIC32MZ2048 a message like "use slower programming speed" How ?

I think this product had been released too early.
Waiting for the next MPLABX release may solve the problems ??
 
I hope!
 
 
 
 

Wolfgang.Schroeder2@gmx.de
#1

21 Replies Related Threads

    RISC
    Super Member
    • Total Posts : 5240
    • Reward points : 0
    • Status: offline
    Re: PICKIT 4 not working 2018/06/08 09:58:24 (permalink)
    0
    Hi,
    MPLAB X new versions are adding gradually new PICs supported (I remember that it was the same when Pickit3 and ICD3 were launched). In the meantime there are hundreds of new PICs...
    See tutorial and list of supported PICs : http://microchipdeveloper.com/pickit4:setup
    Regards
    #2
    Wollli
    Junior Member
    • Total Posts : 56
    • Reward points : 0
    • Joined: 2013/04/06 04:34:46
    • Location: 0
    • Status: offline
    Re: PICKIT 4 not working 2018/06/08 10:04:32 (permalink)
    0
    Hi,
    This pics are all well known, so I could expect that this PIC's are working with new tools...
     
    I wait for a new release, and don't waste time now..
     
     

    Wolfgang.Schroeder2@gmx.de
    #3
    NKurzman
    A Guy on the Net
    • Total Posts : 16122
    • Reward points : 0
    • Joined: 2008/01/16 19:33:48
    • Location: 0
    • Status: offline
    Re: PICKIT 4 not working 2018/06/08 13:06:54 (permalink)
    0
    Are you using MplabX V4.15 or V4.20?
    #4
    Wollli
    Junior Member
    • Total Posts : 56
    • Reward points : 0
    • Joined: 2013/04/06 04:34:46
    • Location: 0
    • Status: offline
    Re: PICKIT 4 not working 2018/06/08 13:08:37 (permalink)
    0
    I'm using V4.15 now better V4.20 ?

    Wolfgang.Schroeder2@gmx.de
    #5
    NKurzman
    A Guy on the Net
    • Total Posts : 16122
    • Reward points : 0
    • Joined: 2008/01/16 19:33:48
    • Location: 0
    • Status: offline
    Re: PICKIT 4 not working 2018/06/08 13:21:09 (permalink)
    0
    V4.15 was the first version.  
    You can see what they added in V4.20
    #6
    Wollli
    Junior Member
    • Total Posts : 56
    • Reward points : 0
    • Joined: 2013/04/06 04:34:46
    • Location: 0
    • Status: offline
    Re: PICKIT 4 not working 2018/06/08 13:23:25 (permalink)
    0
    Ok, I'm just downloading.. hopefully it's getting better :-)

    Wolfgang.Schroeder2@gmx.de
    #7
    Wollli
    Junior Member
    • Total Posts : 56
    • Reward points : 0
    • Joined: 2013/04/06 04:34:46
    • Location: 0
    • Status: offline
    Re: PICKIT 4 not working 2018/06/08 13:26:10 (permalink)
    0
    Oh.. if I download a V4.20 the browser gets a V4.15... very strange!
    I try later if they have solved this problem...
     

    Wolfgang.Schroeder2@gmx.de
    #8
    NKurzman
    A Guy on the Net
    • Total Posts : 16122
    • Reward points : 0
    • Joined: 2008/01/16 19:33:48
    • Location: 0
    • Status: offline
    Re: PICKIT 4 not working 2018/06/08 13:29:56 (permalink)
    0
    Note: The Links are not working yet.
     
    #9
    Wollli
    Junior Member
    • Total Posts : 56
    • Reward points : 0
    • Joined: 2013/04/06 04:34:46
    • Location: 0
    • Status: offline
    Re: PICKIT 4 not working 2018/06/08 13:31:57 (permalink)
    0
    I think they have some problems now :-)
    It's so far not critical for me but it shows that they are a overtaking themselfs currently :-)

    Wolfgang.Schroeder2@gmx.de
    #10
    NKurzman
    A Guy on the Net
    • Total Posts : 16122
    • Reward points : 0
    • Joined: 2008/01/16 19:33:48
    • Location: 0
    • Status: offline
    Re: PICKIT 4 not working 2018/06/08 15:40:15 (permalink)
    0
    There are Hundreds of PICkits, They are going to hit the New PICs and the Popular stuff first.  The Old stuff will be later if at all.  MCC does not support old PICs and may never.
    #11
    Howard Long
    Super Member
    • Total Posts : 380
    • Reward points : 0
    • Joined: 2005/04/04 08:50:32
    • Status: online
    Re: PICKIT 4 not working 2018/06/10 13:25:14 (permalink)
    3 (1)
    I have some good news, my initial indications are that PK4 and ICD4 now debugs at 200MHz speed on PIC32MZ EF with MPLAB 4.20. It also debugs at 140MHz Fosc speed on dsPIC33EP. The PIC32MZ EF used to fail miserably just on simple single stepping.
     
    Debug headers (PEP or EEP) continue to be completely broken in 4.20 with ICD4 and PK4.
    #12
    RISC
    Super Member
    • Total Posts : 5240
    • Reward points : 0
    • Status: offline
    Re: PICKIT 4 not working 2018/06/10 16:00:43 (permalink)
    0
    Hi,
     
    I found a document in MPLAB v4.20 which show the debug headers supported vs the tools :
    c:\Program Files (x86)\Microchip\MPLABX\v4.20\docs\FeatureSupport\HWToolDebugFeatures.html
    If you have issues with a specific header you should raise a ticket if the table above list that the header is already supported for ICD4 / PK4.
    Regards
    #13
    Howard Long
    Super Member
    • Total Posts : 380
    • Reward points : 0
    • Joined: 2005/04/04 08:50:32
    • Status: online
    Re: PICKIT 4 not working 2018/06/12 13:06:09 (permalink)
    0
    RISC: have you tried any headers yourself? So I tried the following debug header PEP/EEPs, the first half dozen in fact on the list. Here are the results under MPLAB X 4.20. 
    </p>
    <p>ICD3
    AC244045 PIC10F322 OK
    AC244051 PIC12F1501 OK
    AC244066 PIC12F1612 No, this EEP hasn't worked since MPLAB X 4.10 with any debugging tool
    AC244043 PIC12F1822 OK
    AC244063 PIC12F1822 OK
    AC162059 PIC12F508 OK</p>
    <p>
    ICD4</p>
    <p>AC244045 PIC10F322 No, *1
    AC244051 PIC12F1501 No, *1
    AC244066 PIC12F1612 No, this EEP hasn't worked since MPLAB X 4.10 with any debugging tool
    AC244043 PIC12F1822 No, *1
    AC244063 PIC12F1822 No, *1
    AC162059 PIC12F508 No, *1</p>
    <p>
    *1 Initialization failed: Failed getting header database information 
    Failed to initialize ICD 4 </p>
    <p> </p>
    <p>PICkit 4</p>
    <p>AC244045 PIC10F322 No, *2
    AC244051 PIC12F1501 No, *2
    AC244066 PIC12F1612 No, this EEP hasn't worked since MPLAB X 4.10 with any debugging tool
    AC244043 PIC12F1822 No, *2
    AC244063 PIC12F1822 No, *2
    AC162059 PIC12F508 No, *2</p>
    <p>
    *2 Initialization failed: Failed getting header database information 
    Failed to initialize PICkit 4 </p>
    <p>
     FWIW, AC244045 and AC162059 don't support software breakpoints on the ICD3. The others do.

    Edit: I suspect that document is mostly what should work, not what does. I already raised tickets for the debug headers not working on ICD4 and PK4, and that the AC244066 hasn’t worked since 4.10.
    post edited by Howard Long - 2018/06/12 13:27:29
    #14
    Wollli
    Junior Member
    • Total Posts : 56
    • Reward points : 0
    • Joined: 2013/04/06 04:34:46
    • Location: 0
    • Status: offline
    Re: PICKIT 4 not working 2018/07/02 02:00:25 (permalink)
    0
    Hello,
    I just gave the PICKIT4 a chance again, then I measured on MCLR / PGC / PGD, and the MCLR
    pin does simply nothing. this can never work ...
    So I think my PICKIT 4 is defect from the beginning of testing with it.
     
    BR
      Wolli
     

    Wolfgang.Schroeder2@gmx.de
    #15
    DevMod1
    Administrator
    • Total Posts : 394
    • Reward points : 0
    • Joined: 2009/02/10 09:34:30
    • Location: 0
    • Status: offline
    Re: PICKIT 4 not working 2018/07/02 09:12:32 (permalink)
    0
    Wollli
    Hello,
    I just gave the PICKIT4 a chance again, then I measured on MCLR / PGC / PGD, and the MCLR
    pin does simply nothing. this can never work ...
    So I think my PICKIT 4 is defect from the beginning of testing with it.
     
    BR
      Wolli
     


    Does MPLAB X recognize your PICKit4?? 

    _____________________________

    Please read the forum posting guidelines. Do not double post, please help keep these forums professional and comments respectful.
    Please notify the moderators of problems/spam/trolls.
    #16
    Wollli
    Junior Member
    • Total Posts : 56
    • Reward points : 0
    • Joined: 2013/04/06 04:34:46
    • Location: 0
    • Status: offline
    Re: PICKIT 4 not working 2018/07/02 09:58:18 (permalink)
    0
    Sure otherwise I could not measure (by Scope) that there is something going on on PGC/PGD..

    Wolfgang.Schroeder2@gmx.de
    #17
    Wollli
    Junior Member
    • Total Posts : 56
    • Reward points : 0
    • Joined: 2013/04/06 04:34:46
    • Location: 0
    • Status: offline
    Re: PICKIT 4 not working 2018/07/08 00:24:25 (permalink)
    3.67 (3)
    Hello ,
     
    in between Microchip shipped a new PICKIT4 to me, and this device is working
    perfectly, as I expect it! So I think the other device, which had been returned to
    Microchip had a defect PIN MCLR from the beginning.
     
    Thank you to Microchip SAR Team.
     
    Best regards
       Wolli

    Wolfgang.Schroeder2@gmx.de
    #18
    ag70
    Junior Member
    • Total Posts : 48
    • Reward points : 0
    • Status: offline
    Re: PICKIT 4 not working 2018/07/13 08:01:27 (permalink)
    2 (1)
    You thanks for what?
    You buyed factory new tool not working, you lost a lot of time. And you thanks?
    #19
    Wollli
    Junior Member
    • Total Posts : 56
    • Reward points : 0
    • Joined: 2013/04/06 04:34:46
    • Location: 0
    • Status: offline
    Re: PICKIT 4 not working 2018/07/13 09:24:33 (permalink)
    5 (5)
    Thanks to the SAR Team, their reaction was very quick.
    Errors can happen everywhere.

    Wolfgang.Schroeder2@gmx.de
    #20
    Page: 12 > Showing page 1 of 2
    Jump to:
    © 2018 APG vNext Commercial Version 4.5