Hot!MCC not generating pin_manager.h 'user functions' for new pin activations

Author
SGK
Starting Member
  • Total Posts : 50
  • Reward points : 0
  • Joined: 2018/05/14 13:55:08
  • Location: 0
  • Status: offline
2018/05/17 07:38:08 (permalink)
0

MCC not generating pin_manager.h 'user functions' for new pin activations

Hi All
 
 - MPLAB X v4.15
 - MCC v3.55.1, core v4.45
 - XC8 v1.45
 - Mac 10.10.5
Microcontrolers:
 - PIC12F1501
 
First post here.  I'm a complete novice to PIC programming (and C) but I have been dabbling around with MCC.  I've managed to code the PIC12F1501 to monitor a switch and control an external timer box for a project I am working on. (I'm not ready to replace the timer box and its internal display and relays.) I'm now trying to add to the project NTC temperature monitoring and PWM fan control. I will likely have to move to a higher pin count PIC for the project but for now I am working with this PIC to try to get things understood. MCC has been very helpful in the daunting (for me) task of setting up the PIC and making some of the code easier. 
 
I've noticed that sometimes when I change a pin designation (or activate a new one) and hit generate, the pin_manager.h file isn't updated for the 'user functions' (forgive me if this isn't the correct term) for the new pin.  As an example, I set pin 4 to be a digital input rather than MCLR. No functions were generated for this pin.
 
Am I doing something wrong?
 
Regards
 
Steve
#1

5 Replies Related Threads

    SGK
    Starting Member
    • Total Posts : 50
    • Reward points : 0
    • Joined: 2018/05/14 13:55:08
    • Location: 0
    • Status: offline
    Re: MCC not generating pin_manager.h 'user functions' for new pin activations 2018/05/17 09:58:43 (permalink)
    0
    Also, and sorry this isn't MCC specific, when I click on Help->Help Contents I just get a blank window...
    #2
    IonutB
    Moderator
    • Total Posts : 98
    • Reward points : 0
    • Joined: 2008/08/04 09:43:55
    • Location: 0
    • Status: offline
    Re: MCC not generating pin_manager.h 'user functions' for new pin activations 2018/05/23 01:12:05 (permalink)
    0
    Hi,
     
    How did you set pin 4 as a GPIO? I am unable to do this using the latest 1.65.2 version of the 8-bit peripheral library and attempting to change the MCLRE config bit from the System Module register view. This is due to an MCC error (ref. MCCV3XX-7867).
     
    The MCC Help is contextual. So if you right-click on an MCC area or a certain MCC UI control, you can access it help content:
     

    Attached Image(s)

    #3
    SGK
    Starting Member
    • Total Posts : 50
    • Reward points : 0
    • Joined: 2018/05/14 13:55:08
    • Location: 0
    • Status: offline
    Re: MCC not generating pin_manager.h 'user functions' for new pin activations 2018/05/23 06:19:48 (permalink)
    0
    I've figured most of this out and moved on but I noticed this thread which comments on the same issue with MCLR
     
    https://www.microchip.com/forums/m1051966.aspx
     
    I noticed it as a problem when I had already asked MCC to generate files and I then wanted to change this pin to GPIO.  
     
    On Help, I was trying to do exactly as this video from Microchip at 2:10. Help->Help Contents.  I get a blank window.
    #4
    SGK
    Starting Member
    • Total Posts : 50
    • Reward points : 0
    • Joined: 2018/05/14 13:55:08
    • Location: 0
    • Status: offline
    Re: MCC not generating pin_manager.h 'user functions' for new pin activations 2018/05/23 06:20:55 (permalink)
    0
    https://www.youtube.com/watch?v=E1_QYNaPClU
     
    Could not edit previous post due to Access Denied. 
    #5
    qɥb
    Monolothic Member
    • Total Posts : 2498
    • Reward points : 0
    • Joined: 2017/09/09 05:07:30
    • Location: Jupiter
    • Status: offline
    Re: MCC not generating pin_manager.h 'user functions' for new pin activations 2018/05/23 06:25:26 (permalink)
    0
    SGK
    ...
    Could not edit previous post due to Access Denied.

    ... because it contained a live URL.
    See: How to avoid errors when editing posts

    PicForum "it just works"
    #6
    Jump to:
    © 2018 APG vNext Trial Version 4.5