Hot!After installing 4.15, many projects fail with odd errors!

Page: < 12 Showing page 2 of 2
Author
Gort2015
Klaatu Barada Nikto
  • Total Posts : 2388
  • Reward points : 0
  • Joined: 2015/04/30 10:49:57
  • Location: 0
  • Status: offline
Re: After installing 4.15, many projects fail with odd errors! 2018/05/17 10:48:41 (permalink)
0
Try creating a new small project to test, i.e. print to uart, flash a led.
Copy and paste you main project into the new one.

MPLab X playing up, bug in your code? Nevermind, Star Trek:Discovery will be with us soon.
https://www.youtube.com/watch?v=Iu1qa8N2ID0
+ ST:Continues, "What Ships are Made for", Q's back.
#21
JohnWill
Starting Member
  • Total Posts : 54
  • Reward points : 0
  • Joined: 2012/07/01 09:36:18
  • Location: 0
  • Status: offline
Re: After installing 4.15, many projects fail with odd errors! 2018/05/17 10:59:47 (permalink)
+1 (1)
JANickerson
There is a firewall at the server in front of the forum software.
You quoted my post which contained an http link.
Use the broken chain icon to break the link before posting

It would be keen if they'd actually throw an error that means something.
 
FWIW, I tried to respond with no quote and no links, and it still throws the same error.  The forum software is broken.
 
Gort2015
Try creating a new small project to test, i.e. print to uart, flash a led.
Copy and paste you main project into the new one.
4.15 compiles and links some of the projects, just not all of them.


#22
Gort2015
Klaatu Barada Nikto
  • Total Posts : 2388
  • Reward points : 0
  • Joined: 2015/04/30 10:49:57
  • Location: 0
  • Status: offline
Re: After installing 4.15, many projects fail with odd errors! 2018/05/17 13:14:49 (permalink)
0
Same compiler version in each project?
Same chip?

MPLab X playing up, bug in your code? Nevermind, Star Trek:Discovery will be with us soon.
https://www.youtube.com/watch?v=Iu1qa8N2ID0
+ ST:Continues, "What Ships are Made for", Q's back.
#23
JohnWill
Starting Member
  • Total Posts : 54
  • Reward points : 0
  • Joined: 2012/07/01 09:36:18
  • Location: 0
  • Status: offline
Re: After installing 4.15, many projects fail with odd errors! 2018/05/17 13:24:48 (permalink)
0
Same compiler, same chip, same source code.
#24
RISC
Super Member
  • Total Posts : 5105
  • Reward points : 0
  • Status: offline
Re: After installing 4.15, many projects fail with odd errors! 2018/05/17 15:18:40 (permalink)
0
Hi,
JohnWill
I've done all of that, and yes it's a .C file.

Can you please confirm that your file extensions are .c (lowercase c) and not Uppercase C (.C) ?
Try to compile the following simple program I generated with MCC on MPLAB X v4.15 + XC8 v1.34 + MCC
Regards

Attachment(s)

Attachments are not available: Download requirements not met
#25
Page: < 12 Showing page 2 of 2
Jump to:
© 2018 APG vNext Commercial Version 4.5