Helpful ReplyHot!Is it necessary to update the ATWINC1500 firmware to use the AT commands?

Author
DominusT
Super Member
  • Total Posts : 1240
  • Reward points : 0
  • Joined: 2005/07/22 08:31:18
  • Status: offline
2018/04/17 05:40:46 (permalink)
0

Is it necessary to update the ATWINC1500 firmware to use the AT commands?

Hi.
 
I am using the ATWINC1500 via RS232 and sent the start command:
 
A5 01 F2 00 00 0C 00 0C 00 61 2F 52 EF

And I get the following response:


(0)NO CORTUS app
(0)(M2M)DriverInfo: None. Assuming 19.3.0
(0)Chip ID = 1524b0
(0)Flash ID = b512302c, Size = 4 MBit
(10)EFUSE:MAC
(10)MAC_ADDR = 8F:F4:35:AB:8C:13
(10)Shared buff static: 0, 5, 5, 22, 9, 10
(20)NMI M2M SW VERSION 19.5.2 SVNREV 14274
(30)NMI MIN DRV VERSION 19.3.0
(30)Firmware SVN URL branches/WIFIIOT-1660_19_5_2_RC7
(30)Built at Jan 26 2017 22:13:34
(40)ROM LIB VER_2
(40)__AES_HW_ENGINE__
(40)(M2M)LOAD SEC
(50)(TLS)TLS Session Size= 1884
(70)PSM_OFF
 
But according to the document AT commands should get a response something similar to the following:

Response +OK+AT=AT:,FW:,ChipID:,RFRev

After the above, I send the "Check the AT Command Firmware" as follows:
 
 case CHECK_AT_COMMAND_FIRMW:{
            app_uart1.transmissionBuffer[0x00] = 'A';
            app_uart1.transmissionBuffer[0x01] = 'T';
                        
            app_uart1.transmissionBuffer[0x02] = 0x0D;
            app_uart1.transmissionBuffer[0x03] = 0x0A;
            
            app_uart1.sizeToTransmit = 0x04;
            break;
        }


But there is no response from the module.


In advance any comments or suggestions are welcome.
#1
jtemples
Super Member
  • Total Posts : 10815
  • Reward points : 0
  • Joined: 2004/02/13 12:31:19
  • Location: Southern California
  • Status: offline
Re: Is it necessary to update the ATWINC1500 firmware to use the AT commands? 2018/04/17 10:12:12 (permalink)
0
I've never seen any documentation indicating there is an AT command mode.  Where did you see that?
#2
DominusT
Super Member
  • Total Posts : 1240
  • Reward points : 0
  • Joined: 2005/07/22 08:31:18
  • Status: offline
Re: Is it necessary to update the ATWINC1500 firmware to use the AT commands? 2018/04/17 10:38:08 (permalink)
0
jtemples
I've never seen any documentation indicating there is an AT command mode.  Where did you see that?


http://ww1.microchip.com/downloads/en/appnotes/atmel-xxxxx-atwinc1500-at-command_applicatio_note.pdf
 
#3
jtemples
Super Member
  • Total Posts : 10815
  • Reward points : 0
  • Joined: 2004/02/13 12:31:19
  • Location: Southern California
  • Status: offline
Re: Is it necessary to update the ATWINC1500 firmware to use the AT commands? 2018/04/17 11:48:56 (permalink)
0
It's not very clear, but it sounds like you have to download the AT firmware to the module first.
 
#4
DominusT
Super Member
  • Total Posts : 1240
  • Reward points : 0
  • Joined: 2005/07/22 08:31:18
  • Status: offline
Re: Is it necessary to update the ATWINC1500 firmware to use the AT commands? 2018/04/18 05:44:56 (permalink)
0
jtemples
It's not very clear, but it sounds like you have to download the AT firmware to the module first.
 


I can not find the files download_all_uart.bat and download_at_cmd_rev_b_uart.bat.


In Harmony there is an installer that has the file download_all_mla_harmony, while the ASF package contains the files download_all.bat and download_all_sb.bat.

I have tried to download those files to the module but the installation fails, possibly due to the USB to RS232 converter is of poor quality (according to the document WINC_Devices_Integrated_Serial_Flash_Download_Procedure.pdf)
#5
jtemples
Super Member
  • Total Posts : 10815
  • Reward points : 0
  • Joined: 2004/02/13 12:31:19
  • Location: Southern California
  • Status: offline
Re: Is it necessary to update the ATWINC1500 firmware to use the AT commands? 2018/04/18 10:12:54 (permalink) ☄ Helpfulby DominusT 2018/04/19 12:16:42
5 (1)
Do you have to use the AT mode?  MLA has example projects using the SPI interface.
#6
DominusT
Super Member
  • Total Posts : 1240
  • Reward points : 0
  • Joined: 2005/07/22 08:31:18
  • Status: offline
Re: Is it necessary to update the ATWINC1500 firmware to use the AT commands? 2018/04/18 10:58:43 (permalink)
0
jtemples
Do you have to use the AT mode?  MLA has example projects using the SPI interface.


I want to use the AT mode since I only want to send some short-length frames via Telnet, with time I could implement higher utilities.
The examples in Harmony are so complex and I must dig in the code to remove what is not useful and also the PIC32 I use does not have enough data memory for the Harmony example.
I will review the example with MLA. thanks for the suggestion.
#7
DominusT
Super Member
  • Total Posts : 1240
  • Reward points : 0
  • Joined: 2005/07/22 08:31:18
  • Status: offline
Re: Is it necessary to update the ATWINC1500 firmware to use the AT commands? 2018/04/19 11:31:41 (permalink)
0
I thought that in the MLA there would be an example to manage the ATWINC1500, but there is nothing.


Manage the SPI port I have no problems. The problem is that there is no list of commands and / or procedures to administer to the module via SPI.


What I have seen in other forums is that they copy the libraries of the module and adapt them for other MCUs.
 
I have indicated to the technical support of MCHp about my problem and this is the answer:
 
"Please note that the last official WINC1500 firmware release that supports the AT Command is v19.4.4. However we have plans to introduce a host level implementation of the AT Command similar application, tentative release date for which is not yet available."
 
Which implies that I must update to that version.
 
What still don't tell me which of all the * .bat files should I download to the module via RS232.
#8
jtemples
Super Member
  • Total Posts : 10815
  • Reward points : 0
  • Joined: 2004/02/13 12:31:19
  • Location: Southern California
  • Status: offline
Re: Is it necessary to update the ATWINC1500 firmware to use the AT commands? 2018/04/19 11:41:58 (permalink)
5 (1)
I thought that in the MLA there would be an example to manage the ATWINC1500, but there is nothing.

 
I'm not sure what you mean.  There is a complete project for PIC18 and PIC24 in the latest MLA.
#9
DominusT
Super Member
  • Total Posts : 1240
  • Reward points : 0
  • Joined: 2005/07/22 08:31:18
  • Status: offline
Re: Is it necessary to update the ATWINC1500 firmware to use the AT commands? 2018/04/19 12:00:49 (permalink)
0
jtemples
I thought that in the MLA there would be an example to manage the ATWINC1500, but there is nothing.

 
I'm not sure what you mean.  There is a complete project for PIC18 and PIC24 in the latest MLA.




 I have the latest version that is v2017_03_06, and I have searched the document TCP / IP about the ATWINC1500 and can not find it. Can you tell me where I should look?
#10
DominusT
Super Member
  • Total Posts : 1240
  • Reward points : 0
  • Joined: 2005/07/22 08:31:18
  • Status: offline
Re: Is it necessary to update the ATWINC1500 firmware to use the AT commands? 2018/04/19 12:16:19 (permalink)
0
jtemples
I thought that in the MLA there would be an example to manage the ATWINC1500, but there is nothing.

 
I'm not sure what you mean.  There is a complete project for PIC18 and PIC24 in the latest MLA.


You are right, I am looking for information here:
C: \ microchip \ mla \ v2017_03_06 \ doc \ help_mla_tcpip.pdf
Within the examples there is documentation related
 
 
#11
jtemples
Super Member
  • Total Posts : 10815
  • Reward points : 0
  • Joined: 2004/02/13 12:31:19
  • Location: Southern California
  • Status: offline
Re: Is it necessary to update the ATWINC1500 firmware to use the AT commands? 2018/04/19 12:20:29 (permalink)
0
The project files are in
 
.../apps/tcpip/wifi_winc1500_demo/
#12
DominusT
Super Member
  • Total Posts : 1240
  • Reward points : 0
  • Joined: 2005/07/22 08:31:18
  • Status: offline
Re: Is it necessary to update the ATWINC1500 firmware to use the AT commands? 2018/04/19 12:33:02 (permalink)
5 (1)
jtemples
The project files are in
 
.../apps/tcpip/wifi_winc1500_demo/


So is!. Thanks for the help. mr green: mr green
 
#13
DominusT
Super Member
  • Total Posts : 1240
  • Reward points : 0
  • Joined: 2005/07/22 08:31:18
  • Status: offline
Re: Is it necessary to update the ATWINC1500 firmware to use the AT commands? 2018/04/20 05:44:53 (permalink)
0
The support of MCHP indicates that there will be no support or updates for the AT commands via RS232, They have provided the old files to work:



"The AT Command application is no more supported officially, however if you want to work with the v19.4.4 version of WINC1500 + AT Command and limited support please use the the attached files for the configuration. You ca find all the files and example applications mentioned in the AT Command document in the attachment"
 
 
My options now are the following:
 
1. Work with the old firmware of the module only for now.
 
2. Wait for the update that someday, they will do it in the not too distant future in which you can send AT commands via SPI.
 
3. Modify the MLA libraries with PIC18F or PIC24F to adapt them to the PIC32.
 
4. Fight with the exessive code of the examples with Harmony.
 
I'm going to analyze option 3 until I get a USB to RS232 converter of quality, since the one that has its TX terminal from the PC generates a lot of noise.
 
Fabián
#14
Ouseppachan
New Member
  • Total Posts : 12
  • Reward points : 0
  • Joined: 2018/06/06 20:54:19
  • Location: 0
  • Status: offline
Re: Is it necessary to update the ATWINC1500 firmware to use the AT commands? 2018/06/07 21:48:07 (permalink)
0
How to start ATWINC 1500 interface with dspic33ep256mc502 spi module.Is it possible to send At commands through spi...?
post edited by Ouseppachan - 2018/06/11 21:44:51
#15
DominusT
Super Member
  • Total Posts : 1240
  • Reward points : 0
  • Joined: 2005/07/22 08:31:18
  • Status: offline
Re: Is it necessary to update the ATWINC1500 firmware to use the AT commands? 2018/07/02 09:44:23 (permalink)
3 (1)
Ouseppachan
How to start ATWINC 1500 interface with dspic33ep256mc502 spi module.Is it possible to send At commands through spi...?


MCHP answer:

"IMPORTANT: Please note that the last official WINC1500 firmware release that supports the AT Command is v19.4.4. However we have plans to introduce a host level implementation of the AT Command similar application, tentative release date for which is not yet available"
#16
Jump to:
© 2018 APG vNext Trial Version 4.5