Hot!Pickit3 Connection Failed

Author
TRGercek
Starting Member
  • Total Posts : 34
  • Reward points : 0
  • Joined: 2017/10/28 11:18:09
  • Location: 0
  • Status: offline
2017/12/15 00:14:25 (permalink)
0

Pickit3 Connection Failed

Hi everyone 
 
After new update of mplabx I can't use mplabx ipe. It gives me this error 
The target circuit may require more power than the debug tool can provide. An external power supply might be necessary.
Connection Failed.
 

Any suggestion ?
 
Have a good day
#1

5 Replies Related Threads

    qɥb
    Monolothic Member
    • Total Posts : 2971
    • Reward points : 0
    • Joined: 2017/09/09 05:07:30
    • Location: Jupiter
    • Status: online
    Re: Pickit3 Connection Failed 2017/12/15 00:43:49 (permalink)
    0
    The most obvious suggestion would be "An external power supply might be necessary".
    How much current does your board require?
    What voltage do you have selected for Vdd?
     

    This forum is mis-configured so it only works correctly if you access it via https protocol.
    The Microchip website links to it using http protocol. Will they ever catch on?
    PicForum "it just works"
    #2
    TRGercek
    Starting Member
    • Total Posts : 34
    • Reward points : 0
    • Joined: 2017/10/28 11:18:09
    • Location: 0
    • Status: offline
    Re: Pickit3 Connection Failed 2017/12/15 01:17:14 (permalink)
    0
    I selected 5V from MPLABX IPE and I tried second way externally 5 Volt is connected  but still doesnt work.
    post edited by TRGercek - 2017/12/15 01:25:02
    #3
    tech24x7
    New Member
    • Total Posts : 25
    • Reward points : 0
    • Joined: 2013/10/14 21:38:52
    • Location: 0
    • Status: offline
    Re: Pickit3 Connection Failed 2017/12/15 01:57:58 (permalink)
    0
    Hi,
    What is your target device?  Please check your VPP line in your target board and ensure its not driving more current.
    #4
    TRGercek
    Starting Member
    • Total Posts : 34
    • Reward points : 0
    • Joined: 2017/10/28 11:18:09
    • Location: 0
    • Status: offline
    Re: Pickit3 Connection Failed 2017/12/15 02:05:15 (permalink)
    0
    And Also I connected Explorer 8 board supplied external 9 V recommended datasheet of explorer8 EVM. Stil giving same error how can I program my pic. Help me please. 
    #5
    tech24x7
    New Member
    • Total Posts : 25
    • Reward points : 0
    • Joined: 2013/10/14 21:38:52
    • Location: 0
    • Status: offline
    Re: Pickit3 Connection Failed 2018/01/12 21:33:37 (permalink)
    0
    Could you try the latest version of MPLABX v4.05, I tried the same with Pickit3 and 16F886 with power target from tool. It works fine.
    Note: If you still feel the issue persist, then go to IPE >> Setting >> UnCheck Auto Firmware and Select Manual Firmware.
    Point your old PK3 firmware file from your old MPLABX.  
    #6
    Jump to:
    © 2018 APG vNext Trial Version 4.5