Hot!Pickit3 connection failed

Author
eduard
New Member
  • Total Posts : 11
  • Reward points : 0
  • Joined: 2012/11/12 12:01:29
  • Location: 0
  • Status: offline
2017/10/07 09:41:11 (permalink)
0

Pickit3 connection failed

I have a strange problem with my pickit3.
I can program and run a pic 16f877a with the programmer, but when I do it once more then I get after a long time waiting connection failed warning. Press the green button again the programmer works almost instancely till the next loading operation.
 
#1

6 Replies Related Threads

    qhb
    Superb Member
    • Total Posts : 5780
    • Reward points : 0
    • Joined: 2016/06/05 14:55:32
    • Location: One step ahead...
    • Status: offline
    Re: Pickit3 connection failed 2017/10/07 14:36:57 (permalink)
    3 (1)
    Connect a resistor (say 1k to 10k) from the PIC's RB3/PGM pin to ground, and see if it improves.
     
    #2
    eduard
    New Member
    • Total Posts : 11
    • Reward points : 0
    • Joined: 2012/11/12 12:01:29
    • Location: 0
    • Status: offline
    Re: Pickit3 connection failed 2017/10/07 15:23:56 (permalink)
    4 (1)
     
     
    Nop still the same problem qhb.
    One time working next one not sometimes when lucky it works 3 times after each other.
     
    @ Dario you mean a link like this one
    http://www.microchip.com/forums/FindPost/1018638
     
    with regards
    Eduard
    #3
    Gort2015
    Klaatu Barada Nikto
    • Total Posts : 1335
    • Reward points : 0
    • Joined: 2015/04/30 10:49:57
    • Location: 0
    • Status: offline
    Re: Pickit3 connection failed 2017/10/07 15:45:01 (permalink)
    4 (1)
    Two threads with the same question. mad: mad
     
    Your connections are ok?
    Have you tried resetting the pickit?

    MPLab X playing up, bug in your code? Nevermind, Star Trek:Discovery will be with us soon.
    https://www.youtube.com/watch?v=Iu1qa8N2ID0
    + ST:Continues, "What Ships are Made for", Q's back.
    #4
    DarioG
    Scheisse Menschen
    • Total Posts : 52394
    • Reward points : 0
    • Joined: 2006/02/25 08:58:22
    • Location: hi there
    • Status: offline
    Re: Pickit3 connection failed 2017/10/07 15:57:02 (permalink)
    0
    yep meant that!
    #5
    eduard
    New Member
    • Total Posts : 11
    • Reward points : 0
    • Joined: 2012/11/12 12:01:29
    • Location: 0
    • Status: offline
    Re: Pickit3 connection failed 2017/10/11 12:33:32 (permalink)
    3.5 (2)
    Solved,
     
    probably something wrong with the USB3 port on my computer or Pic Kit not working well with it.
    Used a USB2 now and it is okee.
     
     
    #6
    Gort2015
    Klaatu Barada Nikto
    • Total Posts : 1335
    • Reward points : 0
    • Joined: 2015/04/30 10:49:57
    • Location: 0
    • Status: offline
    Re: Pickit3 connection failed 2017/10/16 15:58:34 (permalink)
    4 (1)
    I found that mplab x v4 didn't like pickit 3 on usb3 and I had to switch back to usb2.
    Versions before v4 worked ok with usb3.

    MPLab X playing up, bug in your code? Nevermind, Star Trek:Discovery will be with us soon.
    https://www.youtube.com/watch?v=Iu1qa8N2ID0
    + ST:Continues, "What Ships are Made for", Q's back.
    #7
    Jump to:
    © 2017 APG vNext Commercial Version 4.5