Hot!Find Usages & Refactor both 'broken' (v4.01)

Author
sjb741
Super Member
  • Total Posts : 783
  • Reward points : 0
  • Joined: 2010/01/25 08:45:39
  • Location: 0
  • Status: offline
2017/09/29 08:50:48 (permalink)
0

Find Usages & Refactor both 'broken' (v4.01)

Please does someone have an idea what to do about the following (other than wipe the configuration files, which loses all settings)

These features are 'broken' (on my setup at least)...
   (1) Find Usages  -- Always empty
   (2) Refactor|Rename -- Does nothing
 
Also, I keep getting Java errors (I cannot recall exactly what the errors were, or how to find the error logs, I see only very old log files in my 'user' directory).
 
Product Version: MPLAB X IDE v4.01
Java: 1.8.0_141; Java HotSpot(TM) Client VM 25.141-b15
Runtime: Java(TM) SE Runtime Environment 1.8.0_141-b15
System: Windows 7 version 6.1 running on x86; Cp1252; en_GB (mplab)
User directory: C:\Users\sjb\AppData\Roaming\mplab_ide\dev\v4.01
Cache directory: C:\Users\sjb\AppData\Local\mplab_ide\Cache\dev\v4.01\var
#1

5 Replies Related Threads

    Jim Nickerson
    User 452 _
    • Total Posts : 4208
    • Reward points : 0
    • Joined: 2003/11/07 12:35:10
    • Location: San Diego, CA
    • Status: offline
    Re: Find Usages & Refactor both 'broken' (v4.01) 2017/09/29 10:24:34 (permalink)
    0
    I find it mostly works
    I run multiple instances of Mplab X to test if the user dir requires cleaning.
    You can import those settings you want by first exporting them
    This page has info on running multiple instances http://microchipdeveloper.com/mplabx:instances
    #2
    jdeguire
    Super Member
    • Total Posts : 354
    • Reward points : 0
    • Joined: 2012/01/13 07:48:44
    • Location: United States
    • Status: offline
    Re: Find Usages & Refactor both 'broken' (v4.01) 2017/09/29 11:30:45 (permalink)
    +1 (1)
    I've found "Find Usages" to be hit-or-miss, so instead I use "Ctrl + Shift + F" to open up the "Find in Project" dialog and use that instead.
    #3
    Gort2015
    Klaatu Barada Nikto
    • Total Posts : 1473
    • Reward points : 0
    • Joined: 2015/04/30 10:49:57
    • Location: 0
    • Status: offline
    Re: Find Usages & Refactor both 'broken' (v4.01) 2017/09/29 14:36:15 (permalink)
    0 (2)
    Unusally, "Find usages" works for me.
     
    I do use, "find in projects" more though, especially when your project contains many files.
     
    Never use refactor, I just don't trust it to work.
     
    Wipe/clear cache doesn't do any harm, it just takes longer to start next time.

    MPLab X playing up, bug in your code? Nevermind, Star Trek:Discovery will be with us soon.
    https://www.youtube.com/watch?v=Iu1qa8N2ID0
    + ST:Continues, "What Ships are Made for", Q's back.
    #4
    sjb741
    Super Member
    • Total Posts : 783
    • Reward points : 0
    • Joined: 2010/01/25 08:45:39
    • Location: 0
    • Status: offline
    Re: Find Usages & Refactor both 'broken' (v4.01) 2017/09/30 08:58:27 (permalink)
    +1 (1)
    Thanks - It was the cache. I've now found this post, "MPLAB X 3.20 does not do refactoring"
       http://www.microchip.com/forums/m913063.aspx
    Delete C:\Users\YOURUSERNAME\AppData\Local\mplab_ide\Cache\dev\var
    #5
    CinziaG
    rome burns :D
    • Total Posts : 3136
    • Reward points : 0
    • Joined: 2016/12/07 14:20:36
    • Location: Wien
    • Status: offline
    Re: Find Usages & Refactor both 'broken' (v4.01) 2017/10/02 03:12:25 (permalink)
    0 (2)
    Gort2015

     
    Never use refactor, I just don't trust it to work.
     
     



    same here, of course Smile
    #6
    Jump to:
    © 2017 APG vNext Commercial Version 4.5