Hot!MPLABX Ver 4.00 - bug fixes

Page: 1234 > Showing page 1 of 4
Author
Rowlandski
#@>=11
  • Total Posts : 247
  • Reward points : 0
  • Joined: 2008/08/28 02:09:14
  • Location: UK - Herts
  • Status: offline
2017/08/14 04:20:34 (permalink)
0

MPLABX Ver 4.00 - bug fixes

Just downloaded MPLABX 4 and wanted to know what bug fixes have been done, ref:
 
http://www.microchip.com/forums/m1009268.aspx
 
I've been looking through the documentation, I can't find a doc referring to bug fixes.
 
Is it in a subsection of a document?

Current setup/project:
MPLABX V3.55, Win7 64bit, i7 @ 3.4GHz / 16Gb, PICKIT3 & dsPIC33EP512MC806
#1

70 Replies Related Threads

    andersm
    Super Member
    • Total Posts : 2176
    • Reward points : 0
    • Joined: 2012/10/07 14:57:44
    • Location: 0
    • Status: offline
    Re: MPLABX Ver 4.00 - bug fixes 2017/08/14 04:28:01 (permalink)
    +3 (3)
    The release notes have a section titled "Repairs and Enhancements".
    #2
    HowardH
    Super Member
    • Total Posts : 778
    • Reward points : 0
    • Joined: 2006/01/20 10:21:24
    • Location: Microchip Technology - Chandler, AZ
    • Status: offline
    Re: MPLABX Ver 4.00 - bug fixes 2017/08/14 16:23:45 (permalink)
    +2 (2)
    Andersm is correct.  Under C:\Program Files (x86)\Microchip\MPLABX\v4.00\docs, there is a readme for each of the tools.  In each readme, there is a section titled "Repairs and Enhancements".  
     
    Regards,
     
    Howard
    #3
    Gort2015
    Klaatu Barada Nikto
    • Total Posts : 1214
    • Reward points : 0
    • Joined: 2015/04/30 10:49:57
    • Location: 0
    • Status: offline
    Re: MPLABX Ver 4.00 - bug fixes 2017/08/14 17:55:37 (permalink)
    +2 (4)
    MPLab X bugs don't get fixed, they stay on the stack, never to be popped.

    MPLab X playing up, bug in your code? Nevermind, Star Trek:Discovery will be with us soon.
    https://www.youtube.com/watch?v=Iu1qa8N2ID0
    + ST:Continues, "What Ships are Made for", Q's back.
    #4
    Jim Nickerson
    User 452 _
    • Total Posts : 4035
    • Reward points : 0
    • Joined: 2003/11/07 12:35:10
    • Location: San Diego, CA
    • Status: offline
    Re: MPLABX Ver 4.00 - bug fixes 2017/08/15 06:10:03 (permalink)
    0
    Gort2015
    MPLab X bugs don't get fixed, they stay on the stack, never to be popped.

    That might be a little unkind, 4.0 no longer uses the previous version jre 3.65 did which has helped by fixing that bug.
    Yes there are quite a few more to go
    #5
    Gort2015
    Klaatu Barada Nikto
    • Total Posts : 1214
    • Reward points : 0
    • Joined: 2015/04/30 10:49:57
    • Location: 0
    • Status: offline
    Re: MPLABX Ver 4.00 - bug fixes 2017/08/15 08:26:53 (permalink)
    +3 (5)
    No really unkind, all the posts about bugs that never get fixed.  I'm sure many agree with me.
    When a new release comes out, nothing gets mentioned.
     
    The memory allocation, after many compiles, I have to restart mplab x because mplab x allocates memory but does not free it.
     
    Do I need to mention highlighting in C.
     
    Take this for examples, I've mentioned it a few times.
    When editing assembly files, if I highlight some lines and then click the comment icon.
    Instead of ';', I get "# " (hash and space)
    It still works as long as there are no numberals.
    If I uncomment, the hash gets deleted, the space stays.
     
    Extended instructions do not get highlighted in the correct colors.
     
    Major bug
    The properties window.
    addding, deleting and renaming files.
    On restart, you need to go through the process of re-adding the files, you must do this before doing any editing or it will fail again.
     
    Major bug 2
    Renaming a library project, you must remove the file from the libraries folder, rename it then add it back in otherwise if you click on project->properties.
    config:[default]->libraries
    It is blank and you cannot compile because no libraries are listed.
    In that case if you forget to delete it, you have to rename it what it was before to get the list back otherwise it it broken.
    Not smart enough to rename the library in your list.
    post edited by Gort2015 - 2017/08/15 08:29:47

    MPLab X playing up, bug in your code? Nevermind, Star Trek:Discovery will be with us soon.
    https://www.youtube.com/watch?v=Iu1qa8N2ID0
    + ST:Continues, "What Ships are Made for", Q's back.
    #6
    Jim Nickerson
    User 452 _
    • Total Posts : 4035
    • Reward points : 0
    • Joined: 2003/11/07 12:35:10
    • Location: San Diego, CA
    • Status: offline
    Re: MPLABX Ver 4.00 - bug fixes 2017/08/15 08:43:24 (permalink)
    0
    Gort2015
    No really unkind, all the posts about bugs that never get fixed.  I'm sure many agree with me.
    When a new release comes out, nothing gets mentioned.
     

    Yes now that you mention it you have been really unkind.
    Giving credit for fixing some problems is more likely to to get a better response than continuous your poking with a sharp stick.
    Did you not see the andersm and HowardH post about where the changes are noted ?
    Edit: continuous -> your, I was trying to make this not personal/ directed at one individual
    post edited by Jim Nickerson - 2017/08/15 10:01:34
    #7
    Gort2015
    Klaatu Barada Nikto
    • Total Posts : 1214
    • Reward points : 0
    • Joined: 2015/04/30 10:49:57
    • Location: 0
    • Status: offline
    Re: MPLABX Ver 4.00 - bug fixes 2017/08/15 09:51:29 (permalink)
    +2 (2)
    I am not continuosly poking with a sharp stick as you say, I have listed some bugs and I am not speaking just for myself.
     
    You gotta take some criticism in this day.
     
    No, I did not see the post.

    MPLab X playing up, bug in your code? Nevermind, Star Trek:Discovery will be with us soon.
    https://www.youtube.com/watch?v=Iu1qa8N2ID0
    + ST:Continues, "What Ships are Made for", Q's back.
    #8
    Jim Nickerson
    User 452 _
    • Total Posts : 4035
    • Reward points : 0
    • Joined: 2003/11/07 12:35:10
    • Location: San Diego, CA
    • Status: offline
    Re: MPLABX Ver 4.00 - bug fixes 2017/08/15 09:54:46 (permalink)
    0 (2)
    Here you go, just a few posts above:
    http://www.microchip.com/forums/FindPost/1009709
    http://www.microchip.com/forums/FindPost/1009572
    And the 4.0 release announcement mentions see the Release notes
    http://www.microchip.com/forums/FindPost/1009268
    edit: add the release link 
     
     
    post edited by Jim Nickerson - 2017/08/15 10:04:11
    #9
    Jim Nickerson
    User 452 _
    • Total Posts : 4035
    • Reward points : 0
    • Joined: 2003/11/07 12:35:10
    • Location: San Diego, CA
    • Status: offline
    Re: MPLABX Ver 4.00 - bug fixes 2017/08/15 10:11:48 (permalink)
    +2 (2)
    Please do not take my responses the wrong way.
    I do not like all the bugs ( I do not know who does ).
    I would like more of the bugs fixed.
    I think "java" might not have been the best choice but this decision was made by others and it is what we have to work with and I will try to make the best of it.
    Personally I think Visual Studio/ Atmel Studio might have been a better choice (sic).
    This Netbeans/java choice was made before the Atmel acquisition and I understand it would be quite difficult to change now that so much time and effort has been poured into Mplab X and Harmony.
    I am thankful that some of the bugs are getting fixed.
    #10
    dan1138
    Super Member
    • Total Posts : 2542
    • Reward points : 0
    • Status: offline
    Re: MPLABX Ver 4.00 - bug fixes 2017/08/15 10:25:13 (permalink)
    +4 (4)
    JANickerson
    This Netbeans/java choice was made before the Atmel acquisition and I understand it would be quite difficult to change now that so much time and effort has been poured into Mplab X and Harmony.

    When digging a hole in the wrong place the first step in getting out of the hole is to stop digging.
    #11
    Jim Nickerson
    User 452 _
    • Total Posts : 4035
    • Reward points : 0
    • Joined: 2003/11/07 12:35:10
    • Location: San Diego, CA
    • Status: offline
    Re: MPLABX Ver 4.00 - bug fixes 2017/08/15 10:28:49 (permalink)
    0
    Sometimes those doing the digging have little say in the matter, if they want to continue getting paid.
    Then I am quite sure there are those who like these choices...
    I for one have made my views known to those that I know on the inside.
    I have little influence.
    #12
    Gort2015
    Klaatu Barada Nikto
    • Total Posts : 1214
    • Reward points : 0
    • Joined: 2015/04/30 10:49:57
    • Location: 0
    • Status: offline
    Re: MPLABX Ver 4.00 - bug fixes 2017/08/15 10:31:50 (permalink)
    +1 (1)
    Ok, I didn't take it personally.
    Def. Visual Studio, leagues ahead.
     
    Anyhow I have just installed v4 of mplab x and a message pops up to say that pickit 3 not found even though it is in the hardware tools.
     
    I've seen this before and been able to correct it but this time it will not.
    I'll try again later, if not it is back to v3.65.

    MPLab X playing up, bug in your code? Nevermind, Star Trek:Discovery will be with us soon.
    https://www.youtube.com/watch?v=Iu1qa8N2ID0
    + ST:Continues, "What Ships are Made for", Q's back.
    #13
    Jim Nickerson
    User 452 _
    • Total Posts : 4035
    • Reward points : 0
    • Joined: 2003/11/07 12:35:10
    • Location: San Diego, CA
    • Status: offline
    Re: MPLABX Ver 4.00 - bug fixes 2017/08/15 10:44:34 (permalink)
    0
    Mplab X 4.0
    Windows 10, Creators Update
    USB 3 port on PC
    It took a while for Windows to say "it was undergoing further updates"
     

    Attachment(s)

    Attachments are not available: Download requirements not met
    #14
    Gort2015
    Klaatu Barada Nikto
    • Total Posts : 1214
    • Reward points : 0
    • Joined: 2015/04/30 10:49:57
    • Location: 0
    • Status: offline
    Re: MPLABX Ver 4.00 - bug fixes 2017/08/15 14:02:18 (permalink)
    +1 (1)
    MPLab X v4.0 and IPE v4.0.   Both do not regonize pickit 3.
     
     mplab x and ipe v3.65 work.

    MPLab X playing up, bug in your code? Nevermind, Star Trek:Discovery will be with us soon.
    https://www.youtube.com/watch?v=Iu1qa8N2ID0
    + ST:Continues, "What Ships are Made for", Q's back.
    #15
    JuliaDee
    Super Member
    • Total Posts : 165
    • Reward points : 0
    • Joined: 2009/05/04 13:51:40
    • Location: Connecticut
    • Status: offline
    Re: MPLABX Ver 4.00 - bug fixes 2017/08/15 14:39:19 (permalink)
    +1 (1)
    It (3.55 I think) has actually been fairly bug-free for me of late, but the UI gets me down and I have little to no hope of it ever improving. No way to organize watches, no way to sort labels in the navigator alphabetically, stuff like that - details, yes, but oh so important in a tool that we live and breathe and earn our daily bread with. There just seems to be no concern for usability and user experience.

    "Integrity is doing what's right when no one is looking" - J.C. Watts Jr.
    #16
    Gort2015
    Klaatu Barada Nikto
    • Total Posts : 1214
    • Reward points : 0
    • Joined: 2015/04/30 10:49:57
    • Location: 0
    • Status: offline
    Re: MPLABX Ver 4.00 - bug fixes 2017/08/15 16:23:02 (permalink)
    0
    I now how it working.
     
    On v3.65 I had pickit 3 plugged into a ubs3 port, no problem, works fine and has been ages.
    Now with v4, it works on usb2 but not usb3.
     
    I know pickit2 only works on usb2 but it's like v4 has gone backwards.
    usb2 is nearing it's end on modern motherboards.

    MPLab X playing up, bug in your code? Nevermind, Star Trek:Discovery will be with us soon.
    https://www.youtube.com/watch?v=Iu1qa8N2ID0
    + ST:Continues, "What Ships are Made for", Q's back.
    #17
    Jim Nickerson
    User 452 _
    • Total Posts : 4035
    • Reward points : 0
    • Joined: 2003/11/07 12:35:10
    • Location: San Diego, CA
    • Status: offline
    Re: MPLABX Ver 4.00 - bug fixes 2017/08/15 16:35:03 (permalink)
    0
    In my case after it updated the PicKit3 once on USB 2 it worked on USB 3 from then on.
    #18
    Gort2015
    Klaatu Barada Nikto
    • Total Posts : 1214
    • Reward points : 0
    • Joined: 2015/04/30 10:49:57
    • Location: 0
    • Status: offline
    Re: MPLABX Ver 4.00 - bug fixes 2017/08/15 17:05:05 (permalink)
    +1 (1)
    No, it now only works on usb2.
    Plugged it back into usb3 and not found, again works with both on v3.65
     
    Not a problem but a new bug introduced.

    MPLab X playing up, bug in your code? Nevermind, Star Trek:Discovery will be with us soon.
    https://www.youtube.com/watch?v=Iu1qa8N2ID0
    + ST:Continues, "What Ships are Made for", Q's back.
    #19
    ScottSD
    Starting Member
    • Total Posts : 34
    • Reward points : 0
    • Joined: 2016/09/15 12:37:00
    • Location: 0
    • Status: offline
    Re: MPLABX Ver 4.00 - bug fixes 2017/08/25 07:50:17 (permalink)
    0
    I have not bit the bullet and installed 4.00 yet. Does anyone know if the index order of arrays in the Watches window in the correct order in v4.00?
     
    In previous versions arrays are displayed in descending order to a point. Indexes are displayed in descending order by the first significant digit only.
     
    Below is an example of what I am describing:
     
    x[9900..9999]
    x[9800..9899]
    x[9700..9799]
    x[9600..9699]
    x[9500..9599]
    x[9400..9499]
    x[9300..9399]
    x[9200..9299]
    x[9100..9199]
    x[9000..9099]
    x[900..999]            <----------- Why is this out of order?
    x[8900..8999]
     
     
     
    #20
    Page: 1234 > Showing page 1 of 4
    Jump to:
    © 2017 APG vNext Commercial Version 4.5